Back to overview
Degraded

🚨 New Users Experiencing Global Platform Crashes

May 03 at 03:55pm MDT
Affected services
outpost-crm.app

Resolved
May 03 at 06:53pm MDT

We've rolled out a global fix, and this issue should now be resolved for all users.

Updated
May 03 at 06:51pm MDT

The Outpost Core Team has identified the root of this issue, and we are rolling out a fix.

Created
May 03 at 03:55pm MDT

Core platform crashes are affecting ALL new users when accessing their dashboard.

We are working swiftly to resolve this issue.